Minimum

At this current time there is no minimum specs

Windows 7,8,8.1,10

Mac OS X

Ubuntu